NIN Lookup

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 14:49 BST

Investigating

We are actively investigating an issue where the NIN endpoint is returning incomplete data. We apologize for any inconvenience this may cause and will provide timely updates as we work toward a resolution.
Posted Apr 11, 2025 - 11:17 BST
This incident affected: Lookup (NIN Lookup).