Direct Debit: Mandate Service Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 18:25 BST

Update

The service is back up now, and we are monitoring.
Posted Jul 03, 2026 - 15:46 BST

Monitoring

The service is back up now, and we are monitoring.
Posted Jul 03, 2026 - 15:27 BST

Investigating

We are currently experiencing downtime with the e-mandate service. As a result, you may encounter errors when attempting to create a mandate, or mandates may not be approved.
We sincerely apologize for any inconvenience this may cause. We will provide an update as soon as the service is restored.
Posted Jul 03, 2026 - 11:09 BST
This incident affected: Direct Debit (Mandate creation, Mandate Approval, Mono Sweep, Debit Readiness).