Please note that debit processing is relatively stable now. However, mandate approval is still experiencing downtime.
The NIBSS team is actively investigating the issue and working on a fix. We’ll share an update once the service has been fully restored.
We sincerely apologize for any inconvenience this may cause.
Posted Sep 04, 2026 - 17:46 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 08:25 BST
Investigating
We are currently experiencing intermittent downtime from NIBSS impacting the mandate services. This means that you may encounter an error when attempting to create a mandate or initiate a debit. We sincerely apologize for any inconvenience this may cause.
We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Sep 03, 2026 - 16:50 BST
Update
We are currently experiencing intermittent downtime from NIBSS impacting the mandate services. This means that you may encounter an error when attempting to create a mandate or initiate a debit. We sincerely apologize for any inconvenience this may cause.
We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Sep 03, 2026 - 16:50 BST
Monitoring
We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 08:07 BST
Investigating
We are currently investigating an issue affecting the Direct Debit service. This means you may encounter errors when attempting to create a mandate or initiate a debit.
Our Engineering team is actively working to resolve the issue as quickly as possible.
We sincerely apologize for the inconvenience caused and will provide updates as soon as the service is fully restored.
Posted Aug 31, 2026 - 17:20 BST
This incident affected: Direct Debit (Mandate creation, Account debit, Balance enquiry, Mandate Approval, Mono Sweep, Debit Readiness).