M-Pesa Authentication Outage
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 09:35 GMT
Investigating
We are currently looking into a problem where users are experiencing difficulty in authenticating with their M-Pesa login details. Our engineering team is working hard to resolve this, and we will update you once the service is back up and running. We apologize for any inconvenience this may have caused.
Posted Mar 20, 2024 - 09:16 GMT
This incident affected: Financial Connections - Kenya (M-Pesa).