TIN Downtime

Incident Report for Mono

Resolved

This incident has been resolved and the service is back up.
Thank you for your patience.
Posted Jul 06, 2026 - 17:22 BST

Identified

We are currently experiencing downtime with the TIN Lookup endpoint from our provider. We sincerely apologise for any inconvenience this may cause. Our team is monitoring and we will promptly provide an update once the service is fully restored.
Posted Jul 03, 2026 - 12:59 BST
This incident affected: Lookup (TIN Lookup).