A fix has been implemented, and we are monitoring the results.
Posted Oct 29, 2025 - 12:53 GMT
Investigating
We are currently experiencing a downtime from NIBSS, which may cause errors when creating mandates or initiating debits. We sincerely apologize for any inconvenience this may cause. Our team is in active communication with NIBSS to resolve the issue and will provide an update as soon as the service is restored.
Posted Oct 29, 2025 - 08:42 GMT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Oct 27, 2025 - 10:35 GMT
Investigating
We are currently experiencing downtime with NIBSS, which may result in errors when attempting to initiate a debit or balance inquiry. We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Oct 27, 2025 - 07:43 GMT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Oct 26, 2025 - 10:36 GMT
Investigating
We are currently experiencing downtime from NIBSS, which may result in errors when attempting to initiate a debit. We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Oct 26, 2025 - 07:16 GMT
This incident affects: Direct Debit (Mandate creation, Account debit).