BVN Legacy Endpoint Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 22:29 GMT

Investigating

We are currently facing an issue with identity verification on our BVN legacy endpoint as users are unable to verify their BVN identity, and we are actively investigating the cause of this disruption. Our team is actively engaged in resolving this matter, and we're committed to providing timely updates as soon as we gather more information.

We apologise for any inconvenience this may have caused and appreciate your patience and understanding.
Lookup
Posted Mar 16, 2026 - 16:07 GMT
This incident affected: Lookup (BVN Lookup).