Direct Debit: Mandate Approval Downtime

Incident Report for Mono

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 12:02 BST

Investigating

We are currently experiencing a downtime with the e-mandate approval service from our provider. As a result, mandates are not getting approved.
We sincerely apologize for any inconvenience this may cause. We will provide an update as soon as the service is restored.
Posted May 19, 2026 - 17:57 BST
This incident affects: Direct Debit (Mandate Approval, Mono Sweep).