GTB Debit Downtime (Direct Debit)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 09:13 GMT
Investigating
We are currently experiencing downtime from GTBank, which is affecting debit transactions. This means you may receive a 'Do Not Honour' response when attempting a debit.
We sincerely apologize for any inconvenience this may cause and will provide an update as soon as the service is fully restored.
Posted Nov 29, 2024 - 08:30 GMT
This incident affected: Direct Debit connections (GTBank).