Access Bank (Data Retrieval Intermittency)

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 08:31 GMT

Identified

The data retrieval issue is due to intermittent service timeouts from Access Bank. We will provide updates once the service is fully restored and stable.
Posted Jan 29, 2025 - 08:03 GMT

Investigating

We're currently investigating an issue causing data retrieval failures for some Access mobile and internet banking accounts. We apologize for any inconvenience this may have caused and will provide updates shortly.
Posted Jan 17, 2025 - 08:13 GMT
This incident affected: Data Connections - Nigeria (Access Bank).