Access Bank

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 08:31 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2025 - 07:53 GMT

Identified

We've identified a disruption affecting Access Bank's mobile and internet banking connectivity due to upstream connection errors on their end. This is a widespread issue impacting their services. As a result, users won't be able to link their bank accounts for financial data retrieval until Access Bank resolves the matter. We're actively monitoring the situation and will provide updates as soon as possible. We sincerely apologize for any inconvenience caused.
Posted Feb 24, 2025 - 07:50 GMT
This incident affected: Data Connections - Nigeria (Access Bank).