BVN iGree Downtime (bank_accounts)

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 10:22 BST

Investigating

We are currently experiencing downtime from NIBSS, which is affecting the BVN iGree endpoint for bank account retrieval. As a result, you may encounter errors when attempting to validate OTPs or retrieve bank account details.

We sincerely apologize for any inconvenience this may cause and will provide an update as soon as the service is fully restored.
Posted May 23, 2025 - 17:43 BST
This incident affected: Lookup (BVN iGree).