NIBSS Direct Debit Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 08:36 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 09:25 GMT

Investigating

We are currently experiencing downtime from NIBSS, which is affecting the mandate creation, approval and debit services. As a result, mandates are not being approved after users send the N50 fee, and you may encounter an error when attempting to create a mandate or initiate a debit.
We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Mar 18, 2026 - 19:18 GMT
This incident affected: Direct Debit (Mandate creation, Account debit, Mandate Approval).