Fidelity Bank (Authentication Outage)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 09:24 GMT
Investigating
We are currently investigating an issue with the Fidelity retail web connection, which is resulting in a login error when users try to link their accounts for financial data retrieval. Our engineering team is actively working on resolving the issue, and we will keep you informed with updates as they become available.
Posted Mar 20, 2024 - 09:15 GMT
This incident affected: Financial Connections - Nigeria (Fidelity Bank).