Fidelity Bank (Downtime)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 11:40 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 15:53 BST
Investigating
We are currently investigating an issue with the Fidelity Bank retail connection, which is resulting in a timeout error when users try to link their accounts. Our engineering team is actively working on resolving the issue, and we will keep you informed with updates as they become available.
Posted Apr 04, 2024 - 12:10 BST
This incident affected: Financial Connections - Nigeria (Fidelity Bank).