GTBank (Internet Banking Outage)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 13:08 BST
Investigating
We are currently investigating an issue with the internet banking authentication method of the GTbank Nigeria connection, which is resulting in a login error for users trying to link their accounts for financial data access. Our engineering team is diligently working on resolving this, and we will keep you informed with updates as they become available. It is worth noting that this problem is solely for GTB internet, while the mobile authentication method remains unaffected.
Posted Apr 22, 2024 - 09:17 BST