A fix has been implemented, and we are monitoring the results.
Posted May 05, 2026 - 08:44 BST
Investigating
We are currently experiencing downtime with the e-mandate approval service from NIBSS. As a result, mandates are not getting approved. We sincerely apologize for any inconvenience this may cause. We will provide an update as soon as the service is restored.
Posted May 04, 2026 - 16:39 BST
This incident affected: Direct Debit (Mandate Approval).