BVN (iGree) Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted May 16, 2025 - 12:15 BST

Identified

We are currently experiencing downtime with the BVN iGree endpoint from NIBSS. This means you may encounter errors when attempting to initiate a BVN lookup. We sincerely apologize for any inconvenience this may cause and will provide an update as soon as the service is fully restored.
Posted May 16, 2025 - 10:56 BST
This incident affected: Lookup (BVN iGree).