NIBSS Direct Debit Downtime

Incident Report for Mono

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Nov 17, 2025 - 14:53 GMT

Investigating

We are currently experiencing downtime with the mandate creation service from NIBSS. This means that you may encounter an error when attempting to create a mandate.
We sincerely apologize for any inconvenience this may cause and are actively working with the NIBSS team to resolve it. We will provide updates as soon as the service is fully restored.
Posted Nov 17, 2025 - 12:07 GMT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Nov 14, 2025 - 18:29 GMT

Update

We are currently experiencing downtime from NIBSS, which is impacting the Direct Debit service.
This means you may encounter errors when attempting to create a mandate or initiate a debit.
We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Nov 14, 2025 - 16:20 GMT

Investigating

We are currently experiencing intermittent downtime from NIBSS. This means you may encounter an error when attempting to initiate a debit.
We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Nov 12, 2025 - 10:18 GMT
This incident affects: Direct Debit (Mandate creation, Account debit).