The service is back up, and we are monitoring the results.
Posted Jul 30, 2025 - 10:37 BST
Investigating
We are currently experiencing intermittent downtime from NIBSS, which may result in errors when attempting to initiate a debit. We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Jul 29, 2025 - 12:45 BST
This incident affected: Direct Debit (Account debit).