Zenith Bank Corporate (Authentication Outage)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 10:19 BST
Investigating
We are currently investigating an issue with the Zenith Bank corporate connection, which is resulting in a login error for users trying to link their accounts. Our engineering team is working hard to resolve this, and we will update you once the service is back up and running. We apologize for any inconvenience this may have caused.
Posted Jun 20, 2024 - 16:05 BST