NIN Lookup Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted May 13, 2025 - 14:00 BST

Investigating

We are currently experiencing downtime with the NIN endpoint from NIMC. We sincerely apologize for any inconvenience this may cause. Our team is actively working on resolving the issue, and we will promptly provide an update once the service has been restored.
Posted May 13, 2025 - 13:50 BST
This incident affected: Lookup (NIN Lookup).