Zenith Bank Direct Debit
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Nov 03, 2024 - 13:10 GMT
Update
We are continuing to work on a fix for this issue.
Posted Oct 10, 2024 - 17:11 BST
Identified
We have identified a problem where mandates created using Zenith are not working properly for debit and balance inquiries. We are currently working with the Zenith and NIBSS teams to resolve this issue and apologize for any inconvenience caused. We will provide an update within the next 72 hours.
Posted May 05, 2024 - 12:01 BST
This incident affected: Direct Debit connections (Zenith Bank).