Debiting a GTB account via mandate is now working, though not yet for all accounts. However, transactions using the “Pay with Bank” option are still timing out from the bank. We are actively working with the GTBank team to resolve this issue. We apologize for the downtime and any inconvenience caused.
Posted Nov 08, 2024 - 07:22 GMT
Monitoring
GTB account linking is back online, and we’re actively monitoring other services.
Posted Oct 17, 2024 - 07:03 BST
Investigating
Due to ongoing migrations by GTBank, we are currently facing a temporary service downtime, which may affect users' ability to link their GTBank accounts for financial data retrieval, payment initiation, mandate authorization, and account debits. We sincerely apologize for any inconvenience this may cause and are closely monitoring the situation. Updates will be provided as soon as the service is fully restored.
Posted Oct 14, 2024 - 07:35 BST
This incident affected: Pay-with-bank connections (GTBank), Data Connections - Nigeria (GTBank), and Direct Debit connections (GTBank).