A fix has been implemented and we are monitoring the results.
Posted 6 days ago. Mar 26, 2025 - 07:15 GMT
Investigating
We are currently experiencing downtime from Stanbic IBTC, which is impacting debit transactions. As a result, you may encounter errors when attempting a debit. Please note that this issue is from the bank directly, and we are actively working with the NIBSS team to resolve it. We sincerely apologize for any inconvenience this may cause and will provide updates as soon as the service is fully restored.
Posted 8 days ago. Mar 24, 2025 - 08:10 GMT
This incident affects: Direct Debit connections (Stanbic IBTC).