Union Internet Banking
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 09:26 GMT
Investigating
We are presently investigating an issue where users are encountering challenges in authenticating with their Union internet banking login details. Consequently, they are unable to link their accounts for financial data retrieval. Our engineering team is working hard to resolve this, and we will update you once the service is back up and running. It's worth noting that this problem is solely for union internet, while mobile remains unaffected.
Posted Mar 20, 2024 - 09:46 GMT