GTB Downtime
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 08:59 BST
Identified
We've detected a widespread downtime affecting GTB internet and mobile banking services, impacting users attempting to link their accounts or make payments. Our team is actively monitoring the situation, and we'll provide updates as they become available. We apologize for any inconvenience this may have caused.
Posted Apr 04, 2024 - 18:15 BST
This incident affected: Financial Connections - Nigeria (GTBank).