Direct Debit: Mandate Approval Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 16:06 BST

Update

We are continuing to investigate this issue.
Posted Apr 03, 2026 - 13:45 BST

Investigating

We are currently experiencing downtime with the e-mandate approval service. As a result, mandates are not being approved after users send the N50 fee.
We sincerely apologize for any inconvenience this may cause. We will provide an update as soon as the service is restored.
Posted Apr 03, 2026 - 10:57 BST
This incident affected: Direct Debit (Mandate Approval, Mono Sweep).