First Bank Nigeria
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 08:07 GMT
Investigating
We are currently investigating an issue with the First Bank connection where users are experiencing difficulties in linking their accounts for financial data retrieval and payment initiation. Our engineering team is actively working on resolving the issue, and we will keep you informed with updates as they become available.
Posted Mar 14, 2024 - 10:24 GMT
This incident affected: Financial Connections - Nigeria (First Bank).