Fidelity Bank (Authentication Outage)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 10:00 GMT
Investigating
We are currently investigating an issue with the Fidelity retail web connection, which is resulting in a login error when users try to link their accounts. We will keep you informed with updates as they become available.
Posted Feb 27, 2024 - 10:25 GMT
This incident affected: Financial Connections - Nigeria (Fidelity Bank).