The mandate creation and debit initiation services are back up, and we are currently monitoring the results.
Posted Oct 03, 2024 - 13:45 BST
Investigating
We are currently experiencing downtime with the mandate creation and account debit service from NIBSS. This means that you may encounter an error when attempting to create a mandate or attempting a debit. We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Oct 03, 2024 - 12:11 BST
This incident affected: Direct Debit (Mandate creation, Account debit).