Financial Institution Downtime
Incident Report for Mono
Resolved
We've resolved Equity Eazzynet and added Equity online as another login method.
Posted Feb 26, 2023 - 13:26 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 24, 2022 - 10:01 GMT
Identified
We’re currently experiencing downtime with our Equity bank connection. This means that your users won't be able to log into their Equity bank accounts.

Our engineering team is currently working on a fix for this, and we will share an update once the service is back up.
Posted Nov 24, 2022 - 10:00 GMT
This incident affected: Financial Connections - Kenya (Equity Bank).