Sterling Bank (Business) Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Jan 19, 2024 - 09:36 GMT

Investigating

We are currently investigating an issue with the business connection of Sterling Bank Nigeria which is resulting in a login error for users. Our engineering team is working hard to resolve this, and we will update you once the service is back up and running.
Posted Aug 02, 2023 - 14:01 BST