DirectPay Service Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 12:08 BST

Investigating

We are currently investigating an issue affecting authentication and payment completion on DirectPay. This means users may encounter errors while authenticating or trying to complete payments.

Our engineering team is actively working to resolve the issue, and we will provide updates as soon as service is fully restored.

We sincerely apologize for any inconvenience this may cause.
Posted Jul 02, 2026 - 11:46 BST
This incident affected: DirectPay (DirectPay).