Direct Debit: Mandate Approval Downtime

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 09:32 BST

Investigating

We are currently experiencing a downtime with the e-mandate approval service. As a result, mandates are not getting approved.
We sincerely apologize for any inconvenience this may cause. We will provide an update as soon as the service is restored.
Posted Jun 26, 2026 - 08:42 BST
This incident affected: Direct Debit (Mandate Approval).