Elevated CPU Usage Impacting Mono Services

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 16:45 GMT

Investigating

We are currently investigating an issue causing elevated CPU usage across our infrastructure, which is impacting multiple Mono services, including our APIs, widget, and other related systems. Our engineering team is actively working to identify the root cause and restore full stability as quickly as possible. We will continue to share updates as we learn more.

We sincerely apologise for the inconvenience this may cause and appreciate your patience.
Posted Mar 12, 2026 - 15:28 GMT
This incident affected: Financial data (Account Linking, Data retrieval), Mono Pages (Statement Pages, Payment Pages), Product Endpoints (Account, Investment, Data Sync, Identity, Transactions, Payment initiation endpoint, Verify transaction endpoint), Pay-with-bank (Account linking, Payment authorisation, Payment confirmation), Lookup (CAC Lookup, BVN Lookup, BVN iGree, 360View, NIN Lookup, Account number lookup, Address Verification, Passport Lookup, TIN Lookup), Data Connections - Nigeria (First Bank, GTBank, Access Bank, Kuda Bank, Standard Chartered, Stanbic IBTC Bank, FCMB, Zenith Bank, Fidelity Bank, United Bank for Africa, Wallets Africa, Union Bank of Nigeria, Sterling Bank, ALAT by WEMA, Polaris Bank, EcoBank, Jaiz Bank, Unity Bank, Piggyvest, Cowrywise, VULTe Digital Bank, Heritage Bank, Providus Bank, Brass, Globus Bank, Chaka, Risevest, Trove, Paystack, Flutterwave, Opay, Cowrywise, gomoney, Keystone Bank, AltBank, Moniepoint, GTB Corporate), Data Connections - Kenya (Absa Bank, NCBA Bank, KCB Bank, M-Pesa, Stanbic Bank, Equity Bank, Co-Operative Bank), Data Connections - Ghana (Momo, Standard Chartered, Stanbic Bank, Fidelity Bank, Ecobank, GTBank, Airtel Tigo), Telco Data (Authentication, Accounts), Direct Debit (Mandate creation, Account debit, Balance enquiry, Mandate Approval, Mandate Authorization), Pay-with-bank connections (GTBank, Kuda Bank, FCMB Bank, ALAT by Wema, Paga, Pocket), DirectPay (DirectPay (Mobile & Internet banking)), DirectPay Connections (GTB, Opay, Access Bank, Providus), Prove (Authentication, Verification), Direct Debit connections (Zenith Bank, Sterling Bank, Wema Bank, Access Bank, GTBank, UBA, Fidelity Bank, Stanbic IBTC), and Dashboard, Portal, Website, Settlements and Payouts, Pay with Transfer.