GTB Internet Banking (Authentication Downtime)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 08:37 GMT
Investigating
We are currently investigating an issue where users are encountering challenges in authenticating with their GTB internet banking login details. Our engineering team is working hard to resolve this, and we will update you once the service is back up and running.
Posted Mar 21, 2024 - 08:07 GMT