Access Bank (Authentication Outage)
Incident Report for Mono
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 18:51 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2024 - 14:40 BST
Investigating
We are currently investigating an issue where users are encountering difficulties while attempting to log in using their Access internet and mobile banking credentials. Our engineering team is actively working on resolving this issue, and we will provide updates as soon as we have more information.
Posted Apr 26, 2024 - 08:48 BST
This incident affected: Financial Connections - Nigeria (Access Bank).