Connect Widget Service Degradation

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 08:53 GMT

Investigating

We are currently investigating reported cases of users experiencing errors on the Connect widget. Our team is actively looking into the issue and working to resolve it as quickly as possible. We will share an update as soon as we have more information.
Posted Mar 12, 2026 - 08:34 GMT
This incident affected: Financial data (Account Linking).