Financial Data Retrieval

Incident Report for Mono

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 16:18 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2025 - 15:12 BST

Investigating

We are currently investigating an issue affecting financial data retrieval for the following banks on the Connect widget:

GTBank
Opay
Access Bank
Kuda Bank

Our engineering team is actively working to resolve this, and we will provide an update once the service is fully restored. We sincerely apologize for any inconvenience this may have caused.
Posted Sep 16, 2025 - 14:22 BST
This incident affected: Data Connections - Nigeria (GTBank, Access Bank, Kuda Bank, Opay).