NIBSS Direct Debit (Intermittent Downtime)

Incident Report for Mono

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Sep 16, 2025 - 16:51 BST

Investigating

We are currently experiencing downtime from NIBSS impacting the mandate services. This means that you may encounter an error when attempting to create a mandate or initiate a debit.
We sincerely apologize for any inconvenience this may cause. We are in active communication with the NIBSS team to resolve this and will provide an update as soon as the service is restored.
Posted Sep 15, 2025 - 11:29 BST
This incident affects: Direct Debit (Mandate creation, Account debit).