Mpesa System Upgrade
Incident Report for Mono
Resolved
We are happy to announce that the M-Pesa connection is now back on the widget and available for integration.
What's changed?
- API calls to this connection now return debit and credit transactions.
- The narration field now returns full data.
- The account endpoint displays the user's name regardless of account type.
Posted Jul 19, 2022 - 11:37 BST
Identified
We will be temporarily taking M-Pesa off the widget (financial data), to enable us resolve some recurring issues from the financial institution. These issues are because M-Pesa recently had a system upgrade and now returns limited data from connected accounts.
Our team is currently working hard on a resolution and we will share an update once the connection is back on the widget.
Posted Jun 29, 2022 - 14:36 BST
This incident affected: Financial Connections - Kenya (M-Pesa).